FoldaRap/developpement

De fablabo

La Construction

FoldaRap/construction

précision, précision

carte de pilotage

Il s'agit d'une AZTEEG

entretient

Sauvegarde fichiers de config

Le firmware : Fichier:Marlin FoldaRap Ping.zip
les réglages de slic3r : Fichier:ConfigSlic3r FoldaPiNG.ini.zip
le profil cura File:profil.cura.foldarap.ini.zip

Changement du moteur d'extrusion

Sur les conseils d'émmanuel, profitant d'un accident qui cassa la pince de l'extrudeur, nous avons installé un moteur pas à pas Nema14 à la place du motoreducteur précédemment installé.

Cette configuration est normalement plus simple à approvisionner, et la nouvelle pince fonctionne mieux (avec 2 ressors)

Par contre j'ai du mal à faire en sorte que l'extrudeur ne patine pas (en perdant des pas)

réglage du courant sur le driver : OK (0,45V)


compilation du firmware

Il faut suivre les indications sur la page AZteeg de reprap.org et compiler le programme avec arduino 0023 affublé de l'extension hardware/sanguino spéciale pour cette carte.

notre version du firmware : Fichier:Marlin FoldaRap Ping.zip


problème avec gccAvr 4.7.0

Soudain, je m'apperçoi que sur linuxMint Nadia 64bit, l'usage de l'ide arduino V023 (nécessaire à l'écriture du firmware mais obsolète) ne fonctionne pas avec les nouvelles versions des diverses librairies.... Blocage à la compilation... :

/usr/lib/gcc/avr/4.7.0/../../../avr/include/math.h:426:15: error:

J'ai trouvé la solution là : http://code.google.com/p/arduino-tiny/issues/detail?id=29&q=round :

la fonction "round" est déclarée deux fois. Pour régler le problème, il suffit de commenter la ligne //#define round(x) ((x)>=0?(long)((x)+0.5):(long)((x)-0.5))

dans le fichier arduino-0023/hardware/Sanguino/cores/arduino/Wiring.h

Problèmes avec le plateau chauffant

La foldarap est arrivée avec la version du plateau chauffée par un module peltier. Ce système semblait bien marcher, mais rapidement, il a cassé. Nous avons changé le peltier mais la panne revenait.

Nous avons donc décider de ne plus chauffer le plateau, et d'utiliser à la place du scotch 3M 2090 (scotch de masquage bleu) et cela fonctionne bien.


Remplacement du mecanisme de l'extrudeur

Janvier 2015

Suite à une rupture, on remplace l'extrudeur par le dernier modèle avec un moteur plus gros:

https://github.com/EmmanuelG/Foldarap/blob/master/hardware/stl/extruder_nema17.stl

Septembre 2015

la version précédente pose des problèmes

je l'ai modifiée pour guider plus efficacement le filament.

La machine sera compatible avec du matériaux souple.

File:extruderFlex.N17.stl

Les bons réglages

ça fonctionne bien avec la buse à 185° (il faut attendre assez longtemps pour qu'elle monte en température

le plateau à 65° avec du PLA translucide blanc


pilotage avec Cura

http://software.ultimaker.com/